ONLINE SUPPORT DESK

InSource Services Group

RPNow- System Requirements

 

See latest system requirements here.

Operating System

Required Plug-ins

Connection Speed

Date & Time

Other

         
Windows 8.1, 10 Flash is not required

Minimum 300kb/s upload speed^ 

Satellite and Dial-up connections are not supported

Accurate for your local time zone .Net Framework is not required 

MAC  10.13, 10.14, 10.15

Reminder:

Mac OS X 11 Big Sur is currently not supported (Devices updated from Mac OS Catalina to MAC OS Big Sur will still work)

*IMPORTANT* Apple devices released in late 2020 have new M1 processors that have not been certified by PSI, thus are not currently supported. Please monitor this site for further updates.

 

 

Flash is not required 

 

Minimum 300kb/s upload speed^ 

Satellite and Dial-up connections are not supported

 

 

Accurate for your local time zone

 

 

Windows OS not supported on MAC

 

Was this article helpful?
0 out of 0 found this helpful
Have more questions? Submit a request

Comments

Article is closed for comments.